Handling login with force_https to true

I’m still investigating why I cannot login anymore since the last upgrade, with force_https=true.
As I read your comments on meta discourse, I guess we have slightly the same networking configuration
(A VM which is exposed behind a firewall/proxy, and a docker container which runs discourse).
But I keep having this “Can’t verify CSRF authentication …” error (https://meta.discourse.org/t/moved-site-behind-proxy-favicon-and-header-not-using-https-anymore/131486/7?u=rossierd)

And I’ve no (serious) support from Discourse’s team about that.
Finally, how did you solve your issue? (by the way, your logo at top left doesn’t show up correctly on mobile).

Not sure which logo you are referring to @pepsi. Seems to be okay for me on mobile—see images.

RE solution: I was able to get things “working” by modifying the exposed ports in the yml file:

- “80:80” #http
- “443:443” #https

Then rerouted proxy, rebuild app, and enabled force_https — things appear to be working after that. I have personally tried on multiple platforms/browsers as have several of my team members.
image
image

Btw, it would be best to comment on my original post via *meta.discourse. These forums are in no way related to Discourse and are actually part of a completely different dev project.

Yes, sorry about that. But I sent you a message on meta.discourse and I didn’t get an answer… Anyway…Thanks again.
One last thing if I may : did you enable the following lines in your app.yml ?

  • “templates/web.ssl.template.yml”
  • “templates/web.letsencrypt.ssl.template.yml”

Ok then, it’s probably a cache issue with my chrome browser.
I get the logo correctly (I mean your small logo on the same line than “Log in” button only in desktop view, but not in mobile biew… Chrome issue I think

Both have the lines above are commented out because my outside proxy handles encryption/SSL.
image